SEA

R31 Error - A learning aim is missing ??

Created

 
Hi I am getting this error when trying to submit a batch file 
Anyone know how to resolve I have checked and the aim types are correct its an apprenticeship programme with a ZPROG main aim and diploma Component aim all other codes Prog Type, standard code match?
 
A learning aim is missing. You've got an open programme aim in your file, but there's no learning aim with the same 'programme type', 'framework code', 'apprenticeship pathway' and 'standard code'. Make sure all programme aims have at least one associated learning aim with the same 'programme type', 'framework code', 'apprenticeship pathway' and 'standard code'.

 

Replies

No one has replied to this post.


Steveh

Sounds like they haven't got a component aim? Should be the ProgAim (AimType 1) and then at least one component aim (AimType 3)

Steveh

OR (!!!) the component aim hasn't got the right Progtype (25 I'd guess), or Standard Code against it?

SEA

Hi thanks for the reply yes I have these in the codes and component types are correct the only thing I don't have is the EPA cost or company as this is unknown is this creating the error?

Steveh

Nope, should only fire in these circs:


"There is an open programme aim (AimType = 1 and LearnActEndDate = NULL)
AND
there is no component aim (AimType = 3) with the same combination of ProgType, FworkCode, PwayCode and StdCode"


SEA

I fixed it realised it was the funding model drop down on the MIS system hadn't saved !!!!

Steveh

Oh, that's interesting, given funding model isn't one of the fields listed for it to trigger... I mean, it makes sense, but surprised it's not explicit...